Skocz do zawartości

Przenoszenie programu zainstalowanego z Microsoft Store pomiędzy komputerami z Windows 10


Recommended Posts

Na komputerze z Windows 10 mniej więcej rok temu zainstalowałem sobie program Lego Boost dostępnych wówczas w sklepie Microsoft Store.
Kupiłem nowy komputer i chciałem na nim zainstalować ten sam program. Niestety okazało się, że nie jest on już dostępny w tej usłudze. Nie udało mi się również znaleźć jego wersji instalacyjnej nigdzie w internecie. Wszystkie odnośniki, które znalazłem na innych stronach internetowych przekierowywały mnie do Microsoft Store.


Na starym komputerze znalazłem miejsce gdzie ów program został zainstalowany. Przekopiowałem jego katalog (ok. 500MB) na nowy komputer, ale niestety nie udaje mi się go uruchomić. Prawdopodobnie program jest w jakiś sposób powiązany z kontem użytkownika na starym komputerze.
Konta użytkownika zarówno na starym jak i nowym komputerze były tworzone jako offline.
Czy ma ktoś z Was pomysł w jaki sposób przenieść i uruchomić na nowym komputerze ten program?

Link to post
Share on other sites
W dniu 25.11.2020 o 19:22, macfan-pl napisał:

A nie prościej na komputerze źródłowym zalogować się na konto MS, na komputerze docelowym również i wtedy zainstalować z konta?

Używam tylko kont lokalnych. Czy jest możliwość aby zamienić je na konto MS? I czy taki zabieg pozwoli mi zainstalować aplikację, która ze sklepu została usunięta?

@marko22 w weekend przetestuję Twój sposób.

@zbiku90 ja niestety nie mam już skąd pobrać tej aplikacji bo została usunięta ze sklepu :(.

Edytowane przez lokko-1
Link to post
Share on other sites

Nie udało mi się zainstalować programu w sposób jaki zaproponowaliście.

@marko22 nie wiem dlaczego, ale tej konkretnej aplikacji, która została zainstalowana ze sklepu Microsoft zaproponowany przez Ciebie program nie widział.

@BlackCoffe Twój sposób również nie przyniósł zamierzonego efektu. Co prawda w inny sposób udało mi się zamienić konto lokalne na Microsoft, ale w dalszym ciągu nie miałem możliwości zainstalowania programu na drugim komputerze. Program ów nie był widoczny w bibliotece moich programów.

Udało mi się rozwiązać problem w inny sposób.
Na jednej z rosyjskojęzycznych stron natrafiłem na podany tam link, który jak się okazało kierował do strony konwertującej linki do programów, które można zainstalować wprost ze sklepu na takie, które umożliwiają ich pobranie na dysk komputera.
Znając link pod jakim program był dostępny w Microsoft Store mogłem ściągnąć jego instalkę *.appx i bez problemu zainstalować na świeżym Windows 10.

Ta strona to: https://store.rg-adguard.net może komuś się przyda.
Wpisując w jej wyszukiwarce link do programu Lego Boost (w dalszym ciągu dostępny w Microsoft Store, ale bez możliwości jego zainstalowania): https://www.microsoft.com/pl-pl/p/lego-boost/9nzn5q1ck1qk zostają wygenerowane linki do pobrania programu. Ten o rozmiarze ~360MB jest dla PC, a większy o rozmiarze ~650MB podobno dla XBOX.

 

Edytowane przez lokko-1
  • Lubię to 2
  • Popieram 1
Link to post
Share on other sites

Jeśli zastanawiasz się jak rozwiązać jakiś problem zajrzyj na rosyjskie forum. Okaże się że problem został już rozwiązany na 10 różnych sposobów :D Gratuluję determinacji i dzięki za podzielenie się rozwiązaniem, to rzadkość w tych czasach a świadczy o wysokiej kulturze usera. Pozdro.

Link to post
Share on other sites

Za wcześnie odtrąbiłem sukces.

Raz udało mi się zainstalować pobraną aplikację - jej rozszerzenie to .AppxBundle. I na tym skończyły się moje odnoszące skutek działania.

Po przeinstalowaniu Windowsa (miałem bałagan na dysku) i ponownej instalacji aplikacji gdy ją uruchamiam za każdym razem otrzymuję komunikat:

Licencja LEGO® BOOST nie jest obecnie dostępna na Twoim koncie. Upewnij się, że zalogowano się do sklepu Microsoft Store i spróbuj ponownie. Dołączamy kod błędu, gdyby był Ci potrzebny: 0x803F8001.

Gdy próbuję uruchomić ją bez dostępu do sieci, to nie udaje mi się to. Mignie chwilę ekran i na tym koniec.

Dziwniejsze jest jeszcze to, że po sklonowaniu systemu ze starego komputera (gdzie mam jeszcze działającą ww. aplikację) i odtworzeniu klona na maszynie wirtualnej VirtualBox aplikacji tej również nie daje mi się uruchomić.

Nie rozumiem w jaki sposób instalowane są aplikacje ze sklepu Microsoft i jakie powstają zależności pomiędzy sklepem, OS i zainstalowaną aplikacją.

 

Link to post
Share on other sites
W dniu 1.12.2020 o 22:52, zbiku90 napisał:

Ten sam sposób co wcześniej zastosowałeś nie działa?

Tak, w ten sam sposób.

Jedyna różnica to taka, że za pierwszym razem instalowałem Lego Boost (z pobranego na dysk instalatora) na komputerze z Windows 10, który był postawiony w tamtym roku - wtedy mi zadziałało. Natomiast za drugim razem na świeżo zainstalowanym Windows 10 już to mi się nie udało. Może w pierwszym przypadku w systemie był zainstalowany jakiś dodatek (zainstalowany przy okazji instalacji innych programów), który pozwalał ominąć błąd 0x803F8001. Trudno mi to teraz stwierdzić.

 

Jeszcze inaczej próbowałem obejść ten problem. Otóż zrobiłem sobie kopię dysku z Windowsem i zainstalowanym działającym Lego Boost'em. Następnie na innym komputerze odpaliłem maszynę wirtualną i odtworzyłem na niej ww. kopię. Ku mojemu zdziwieniu Lego Boost nie zadziałał - błąd 0x803F8001. Podczas gdy inne programy uruchamiały się bez problemu. Lego Boost był jedyną aplikacją instalowaną z app store. Microsoft Store - sądzę, że to jest źródło problemów i jego jakiś wewnętrzny mechanizm sprawdzający możliwość odpalenia aplikacji z danego konta. Tylko jak on może cokolwiek sprawdzić, skoro używam wyłącznie kont lokalnych.

 

@marko22działa Ci w emulatorze Bluetooth i łączy się z Lego Boost? Postawiłem maszynę wirtualną, a na niej Androida x86. Nawet stawiałem go jako osobny system operacyjny, ale nie udało mi się uruchomić Bluetooth, który jak wiadomo jest konieczny do komunikacji z klockami.

Edytowane przez lokko-1
Link to post
Share on other sites

A widzisz.....tego nie sprawdziłem. Tylko nie bardzo wiem, jak mam to sprawdzić, bo takich klocków nie posiadam.

 

https://blissos.org/ Spróbuj zainstalować sobie to na USB. Odpalasz jako oddzielny system na kompie. Może to w końcu Ci zadziała. Emulatory z tego co czytam, nie obsługują BT.

 

E: No tak....ale już to robiłeś. Tylko z jaką wersją? Próbuj. Coś w końcu może zadziała. Ale dziwne, bo Android x86 niby zawiera obsługę BT.

Edytowane przez marko22
Link to post
Share on other sites

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz w tym wątku...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...