Skocz do zawartości


Uwaga, ta strona używa Cookies
Stosujemy je, aby ułatwić Tobie korzystanie z naszego serwisu. Pamiętaj, że w każdej chwili możesz zmienić ustawienia dotyczące Cookies w ustawieniach swojej przeglądarki internetowej.
Dowiedz się więcej    
Akceptuję
Zdjęcie

Samsung SM951 256GB SSD pod M.2 - problem

ssd windows PCie SM951 M.2

  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 Alnervik

Alnervik
  • Nowicjusz

  • 7 postów

Napisano 20 listopad 2015 - 10:41

Cześć,

Mam problem i już nie wiem, jak to ugryźć.

 

Przyszedł do mnie komputer złożony w Morele. W komputerze jest SSD pod M.2 - Dysk SSD Samsung 256GB PCIe 3.0 (MZHPV256HDGL-00000) - na którym chciałabym zainstalować system. W komputerze jest też drugi SSD, standardowy - Dysk SSD Samsung 850 PRO 256GB SATA3 (MZ-7KE256BW) - na którym system postawiłam. Chciałam na tym pod M.2, ale w konfiguratorze Windowsa nazywały się dokładnie tak samo i mając 50% szans oczywiście spudłowałam.

Wiem już, że chcąc zainstalować system na M.2 powinnam ten drugi dysk odpiąć dla pewności - i to mam zamiar zrobić.

 

Natomiast problem jest taki, że oba dyski widnieją w systemie jako SATA (jak wynika z programu benchmarkującego), a tym samym ten na M.2 nie osiąga prędkości jakie mógłby osiągać (i rzeczywiście nie osiąga, jak wynika z programu benchmarkującego).

Grzebanie w BIOSie wywołuje u mnie gniew i zrezygnowanie. Czy jest na sali jakiś czarodziej, który mógłby opisać mi, co włączyć i co wyłączyć, żeby uzyskać pożądany efekt, tj. turbowindowsa na M.2 pod PCIe?

Moim jedynym źródłem wiedzy są komentarze o tym dysku na newegg.com - gdzie piszą głównie, żeby odrobić swoje zadanie domowe, zanim się ten dysk z sukcesem postawi. Thanks Obama.

 

 

Wiem, że to nie jest jeszcze popularna konfiguracja, ale może jest ktoś, kto niedawno robił coś podobnego i operację zakończył sukcesem. Będę bardzo wdzięczna za jakieś wskazówki.

 

Dane:

System: oryginalny Windows 8.1 Pro [6.3 Build 9600] (x64) z USB (stworzony z ISO przy pomocy Rufusa pod UEFI)

Motherboard: MSI X99A SLI Plus, Intel X99, Socket 2011-V3 (7885-023R)

Model BIOSu: Nie wiem, sprawdzę; komputer jest nowy, BIOS powinien być najaktualniejszy.

Dysk pod M.2: Dysk SSD Samsung 256GB PCIe 3.0 (MZHPV256HDGL-00000)

Dysk drugi: Dysk SSD Samsung 850 PRO 256GB SATA3 (MZ-7KE256BW)


  • 0

#2 tomasz.kostka.39

tomasz.kostka.39
  • Nowicjusz

  • 9 postów

Napisano 20 listopad 2015 - 15:32

Wiem że złącze m.2, jeżeli jest zamocowany w nim dysk... zabiera jedno sata
  • 0

#3 kokosnh

kokosnh
  • Maniak

  • 10650 postów
  • 3DMark 06:24404

Napisano 20 listopad 2015 - 18:04

MZHPV256HDGL-00000 jest na AHCI, nie na NVMe, tego nie przyśpieszysz... 
prawdopodobnie to właśnie kontroler ogranicza 

Jakie dokładnie wyniki uzyskujesz ? 


bo mimo kontrolera to odczyt i zapis sekwencyjny powinny być tak wysokie, jak deklarowane ( to operacje na mniejszych plikach leżą przez AHCI, nie maksymalny zapis/odczyt ) 


Użytkownik kokosnh edytował ten post 20 listopad 2015 - 18:05

  • 0

Spoiler

#4 Franz

Franz
  • Gaduła

  • 397 postów

Napisano 20 listopad 2015 - 18:05

Po pierwsze musisz mieć najnowszy BIOS dla danej płyty, by poprawnie obsługiwała te SSD Samsunga jako napędy bootowalne na system.

Po drugie znalazłem info, że w Biosie powinno być ustawione w pozycji: M.2 Source Link na "Auto", a nie "PCH".

Dwa pierwsze fakty mogą powodować, że system nie chce się dać zainstalować na Samsungu.

 

Po trzecie znalazłem też info, że ta płyta MSI, by obsługiwać złącze M.2 z pełną prędkością PCIE x4 potrzebuje procesora z 40 liniami PCIE, czyli np. z takim 5820K zadziała, ale tylko z PCIE x2 - być może to powoduje gorsze osiągi, o ile oczywiście nie masz procesora z 40 liniami.

Co do benchmarków pokazujących, że to SSD z SATA to musi być błąd, bo ten SSD nie wystartowałby na złączu M.2 z obsługą SATA zamiast PCIE.

 

Jeżeli problemem jest to, że Samsung nie osiąga pełnej prędkości w złączu M.2 z procesorem z 28 liniami (np. 5820K) to rozwiązaniem może być przejściówka z PCIE na M.2 do kupienia w cenie od ok. 25-60 USD (nie sprawdzałem czy są dostępne w polskich sklepach, ale niewykluczone).


  • 0

#5 Alnervik

Alnervik
  • Autor tematu
  • Nowicjusz

  • 7 postów

Napisano 24 listopad 2015 - 14:49

Dziękuję wszystkim, mamy to :) Prędkości nadźwiękowe, Windows wstaje w kilkanaście sekund, jest tak jak być powinno.


  • 0

#6 kamigava

kamigava
  • Nowicjusz

  • 5 postów

Napisano 17 grudzień 2015 - 00:03

Możesz powiedzieć które rozwiązanie zastosowała, co Pozwoliło osiągnąć ta prędkość? Za kilka dni ja będę miał.w domu podobny konfig, to samo mobo i dysk. I 5820k
  • 0

#7 Asus33

Asus33
  • Nowicjusz

  • 2 postów

Napisano 25 grudzień 2015 - 09:03

Mam pytanie do obeznanych, posiadam laptopa asus a501lx (nowy tegoroczny) i jest taki oto problem, wewątrz w tymże komputerze jest wejście m.2 albo coś kompatybilnego (bo mało danych szczegółowych o samym laptopie w internecie) przy którym dodatkowo napisane jest SSD. Zakupiłem pamięć  SSD Samsung 128GB PCIe 3.0 (MZHPV128HDGL-0000)  sm951, pierwsze wrażenia - wszystko pasuje glancuś elegancuś - włączenie notebooka = włącza sie i po 2s od razu wyłącza -> po aktualizcji biosa, która to teoretycznie miała naprawiać problemy z pamięciami samsunga -> klapa, laptop z tym dyskiem nie chce współpracować - czy ktoś może powiedzieć co w tym przypadku zrobić, czy wymienić na coś starszego czy co ???

Za jakąkolwiek odpowiedź dziękuję


  • 0

#8 Franz

Franz
  • Gaduła

  • 397 postów

Napisano 28 grudzień 2015 - 13:22

Jesteś pewien, że ten Asus obsługuje na złączu M.2 SSD z interfejsem PCIE, czyli takie jak ten Samsung sm951?

 

Jest wiele laptopów na rynku, które na złączu M.2 obsługują wyłącznie SSD z SATA III i to może być niestety problemem - jeżeli tak jest to pozostaje Tobie pozbycie się tego Samsunga i dokupienie jakiegoś SSD z SATA III - oczywiście zaden SSD na z SATA nie osiągnie takich prędkości jak ten Samsung.

 

Rzeczywiście mało informacji w sieci o tym laptopie i nie znalazłem nic o tym jakie interfejsy obsługuje złącze M.2 - jest tylko krótka informacja, że może mieć SSD M.2 o długości 2280 i pojemnościach 128 i 256 GB.


Użytkownik Franz edytował ten post 28 grudzień 2015 - 13:29

  • 0

#9 Asus33

Asus33
  • Nowicjusz

  • 2 postów

Napisano 04 styczeń 2016 - 11:01

Tak, pozostało tę pamięć oddać, bo potrzebne jest ssd z sata3, ale kłopot jest z samym wejściem (nie sprawdzałem żadnej innej pamięci) w laptopie jest takie jaką ma ta nowa pamięć, czyli z jednej strony wcięcie, a wszystkie pamięci które sprawdzałem (w internecie) o rzekomo poprawnych parametrach m.2 i sata3 mają dwa wcięcia... więc co jest grane ? Czy te pamięci też będą działać w tym laptopie ??


Użytkownik Asus33 edytował ten post 04 styczeń 2016 - 11:02

  • 0

#10 Franz

Franz
  • Gaduła

  • 397 postów

Napisano 04 styczeń 2016 - 23:52

Jeżeli masz w laptopie złącze M.2 obsługujące SATA i kupisz SSD M.2 z SATA to powinno to działać.

 

Co do wcięć:

dwa wcięcia mają SSD M.2 obsługujące interfejs SATA III,

a jedno wcięcie SSD M.2 z interfejsem PCIE x4 (takie jak ten Samsung co chciałeś zamontować i nie działał).

Złącze fizycznie jest takie samo - bez względu czy obsługuje SATA III, czy PCIE, czy oba na raz, a co obsługuje takie M.2 zależy od tego jak je podłączył producent laptopa, czy płyty głównej. Dlatego mogłeś wsadzić w to złącze SSD z PCIE, ale skoro producent laptopa umożliwił na tym M.2 działanie tylko SATA to nie zadziałał.


  • 0

#11 zanet

zanet
  • Nowicjusz

  • 9 postów

Napisano 20 kwiecień 2018 - 08:29

Witam

Mam problem z płytą Asus Rampage Extream IV i dyskiem Samsung Sm951 NvMe na adapterze do PCIe.

Mam wgrany najnowszy dostępny na stronie Asusa bios.

W biosie dysk nie jest widoczny ale jeśli uruchomię program np. GParted to dysk widzi.

Jakie zrobić ustawienia biosu aby dysk był widoczny?

pozdrawiam


Użytkownik zanet edytował ten post 20 kwiecień 2018 - 08:29

  • 0





Również z jednym lub większą ilością słów kluczowych: ssd, windows, PCie, SM951, M.2

Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych