Skocz do zawartości

Wiedźmin 3 - Problem z fps na nienajgorszym sprzęcie


Go to solution Solved by WertozX,

Recommended Posts

Witam, Mam problem z wydajnością w Wiedźminie 3 w novigradzie. Fpsy dropia do 37fps, użycie gpu oscyluje w 60%. (nieważne jakie ustawienia graficzne i rozdzielczość fpsy bez zmian). Poza novigradem użycie jest normalne i klatek jest 100. Wydaje mi się, ze na tym sprzęcie nie powinna mieć miejsca tak niska wydajność, w testach youtube na tym samym sprzęcie ludzie osiągają spokojnie 70-85 fpsów. W innych grach jak Dirt rally 2.0 czy Gta 5 wydajność jest taka jak powinna być, czyli grubo ponad 60 klatek na max ustawieniach. Sprawdzałem wszystkie rozwiązania jakie znalazłem na forach, nvidia control panel, opcje zasilania maksymalna wydajność, wszystkie layouty typu geforce expirience wyłączone, vsync wyłączałem, włączałem, tryb okna bez ramek itp. Testowane na dysku HDD i SSD. Najnowsze sterowniki, najnowszy bios. Gram na rozdzielczości 1920x1080.
Specyfikacja Komputera:
Płyta Główna: Gigabyte B450 AORUS ELITE
Procesor: AMD Ryzen 7 2700x (Z chłodzeniem Be quiet Dark rock 4)
Karta Graficzna: MSI GeForce GTX 1070 GAMING X 8GB GDDR5
Ram: G.SKILL 16GB 3200MHz Ripjaws V Black CL16 (w dwóch kościach po 8gb)
Zasilacz: Be quiet Dark Power Pro 11 650w

Z góry dziękuje za każda pomoc :)

Edytowane przez WertozX
Link to post
Share on other sites

Witam. Novigard w Wiedźminie 3 to słynny już dusiciel CPU który wiele procków sprowadził grubo poniżej 60FPS. Jednak wydaje mi się że powinieneś mieć nieco lepszy wynik. Tak profilaktycznie; CPU działa z docelowym zegarem? W opcjach zasilania Windows, jaki profil jest włączony? (wydajność/zrównoważony/oszczędny itp)?

 

EDIT:

Ostatecznie spróbuj wyłączyć w panelu programu RyzenMaster (ewentualnie w UEFI) SMT procesora, czyli tymczasowo zrobić z niego 8C/8T (zamiast 8C/16T), w niektórych przypadkach dawało to pewne przyspieszenie, choć raczej w starszych (acz cięższych wobec CPU) tytułach.

Edytowane przez Eternal1
Link to post
Share on other sites

gdzieś kiedyś wyczytałem, że Trzeci Wiesiek korzysta tylko z 4ech rdzeni a i kiepsko radzi sobie z HT ( czyt. wogóle sobie nie radzi), więc konkluzja taka ...Twój Ryży jednordzeniowo to poziom i piątki z 2013 roku ( XD ) 

 

mam na dzieję, że pomogłem

Edytowane przez Elomin
Link to post
Share on other sites

@Elomin jakieś głupoty wyczytałeś. W3 wyjątkowo dobrze korzysta z dodatkowych rdzeni czego dowodem jest duża różnica wydajności między 7700K i 8700K w Nowigradzie z nieprzyzwoicie drogą kartą graficzną w 1080p.

 

Taki ryzen 1600 był szybszy niż 4 rdzeniowa i5, a w większości gier z 2015 to i5 miała wyraźną przewagę.

 

W architekturze Zen+ czyli Ryzeny 2000 w grach między 6, a 8 rdzeniami nie ma różnicy, ale z nowych w tyle zostają 4rdzeniowce, nawet mocno wykręcone intele.

Link to post
Share on other sites
  • Solution
Napisano (edytowane)

Niestety, żadna z powyższych odpowiedzi nie pomogła. Ramy wsadzone mam dobrze, według slotów w instrukcji, w gpu-z, biosie i menadzerze zadań pokazuje odpowiednia predkosc ramu. Wyłączenie SMT w biosie nic nie daje. Geforce experience odinstalowane. Przypominam, że to dotyczy tylko wiedźmina, w każdej innej grze FPSy są takie jak na testach youtube. Problem występuje TYLKO w wiedźminie i TYLKO w novigradzie (być moze problem pojawiłby sie jeszcze w pozniejszych wiekszych miastach, tego nie wiem, bo nie pcham fabuly do przodu dopoki nie rozwiaze tego kuriozalnego problemu).
Gpu wtedy pracuje na 40-60% i klatki oscyluja od 35-48 fps, poza novigradem natomiast gpu pracuje na 90-100% i wtedy klatki skacza nawet i do 90 fpsów.
Wstawiam rozgrywke z novigradu z właczonym monitorowaniem cpu, gpu itp. Moze ktos znajdzie cos niepokojacego i bedzie w stanie pomoc?


EDIT:
PROBLEM ROZWIĄZANY!
Zaktualizowanie systemu z 1809 do 1909 załatwiło sprawę. Dziękuje wszystkim za pomoc  
Edytowane przez WertozX
Link to post
Share on other sites

Wiedźmin 3 to dziwna gra, za każdym razem jak do niej wracam działa inaczej, w 2015 na 4670k i R9 290 grałem na wysokich z dropami do 45 fps, Później na tym samym kompie już chodziła na wysokich w 60fps, później zmieniłem sprzęt na ten ze stopki, było ultra stałe 60 fps, później miałem dropy w lesie pod wieczór do 50 fps a karta szła jak szalona, potem problem zniknął, chyba gra się różnie zachowuje w zależności od sterowników, wersji windowsa i diabeł wie od czego jeszcze

Link to post
Share on other sites
Gość
This topic is now closed to further replies.
×
×
  • Dodaj nową pozycję...