Skocz do zawartości

Okropne szarpanie gier po zmianie karty graficznej


Recommended Posts

Witam, borykam się z problemem przycinania gier głównie przy wczytywaniu większej ilości textur, animacji itd, wygląda to w taki sposób że np mam stałe 60fps i nagle gra się na chwile przytnie i w tym momencie sypią się fps nawet 20 i wracają z powrotem do 60. Podam przykłady jak to wygląda w grach, przy włączeniu gta 5 jest wszystko okej ale tnie mi cała mapa kiedy przesuwam myszką, pod czas rozgrywki przycięcia występują po czasie co raz częściej, w Dishonored 2 przycięcia występowały razem z przycinaniem dźwięku, Wiedźmin 3 najbardziej przycina w mieście a najmniej na jakiś polach gdzie jest mało obiektów a zdarz się że nie występuje wcale, stary NFS MW z 2005 radzi sobie bez problemu,far cry 3 głównie tnie w cutscenkach, gothic 2 potrafi nawet mulić, Fallout 4 chodzi znośnie, przycinki są rzadkie, za to bardzo dziwne że gry od firmy From Software nie tną praktycznie w ogóle, wszystkie Dark Soulsy 123 chodzą praktycznie bez scin, zdarza się czasem posypać ale to bardzo rzadko, ostatnio ogrywam Sekiro i jak na grę która wyszła bardzo nie dawno gra chodzi idealnie jak i solsy, przycięcia występują tylko po przybyciu na nową lokacje i później jest już spokój, Fortnite chodzi tragicznie pierwszy mecz, w drugim się już uspokaja.Najlepiej widać okropne przycięcia w Resident Evil 2,proszę sobie wyobrazić jak to wygląda: chodząc w jednym pomieszczeniu gra zachowuje się normalnie ale kiedy już mam zamiar przejść przez drzwi do innej lokacji gra przycina okropnie, aby za chwile wrócic do normalnosci, pierwszy wystrzał z broni po uruchomieniu gry kończy się takim samym lagiem co opisałem wcześniej, poźniej tez występuje ale mniej i delikatniej,Assassin Creed Origins , wiadomo lagi w mieście i np kiedy Senu(ten ptak) wyłączam go kamera gry wraca na postać robią się takie lagi, w większosci gier widze jak doczytują sie mi nie które textury mniejsze ale nie w każdej, problem polega głównie na tym i tu według mnie najlepsze spostrzeżenie: przycięcia występują w momentach kiedy na ekranie wydarzyć ma się cos nowego, wybuch wystrzał uderzenie, płomien, co kolwiek nowego to są przycięcia. Zmiana ustawien graficznych na niskie wysokie ultra nic nie daje, tnie na obojętnie jakich, format robiony, zero wirusów, śmieci na kompie, zero podejrzanych procesów działących w tle. Proszę o pomoc i darowanie sobie pisania komenatrzy typu: za słaby komputer, za dużo wymagam, kup lepszy ja o tym wiem że mogę kupic ale przed zmianą karty graficznej było wszystko okej, ta karta co teraz mam byla oddawana do sklepu i dali mi taką samą drugą więc to nie wina że z kartą jest coś nie tak. Wczesniej było wszystko okej bez żadnych problemów.

 

specyfikacja:

procesor i5 4460

karta graficzna: teraz GTX 1050 2GB, wczesniej Radeon R7 240 2gb

Zasilacz 450w(nie pamiętam nazwy)

płyta główna msi h110m

Ram 8gb single channel

 

 

 

Link to post
Share on other sites

 

specyfikacja:

procesor i5 4460

karta graficzna: teraz GTX 1050 2GB, wczesniej Radeon R7 240 2gb

Zasilacz 450w(nie pamiętam nazwy)

płyta główna msi h110m

Ram 8gb single channel

 

 

 

Te dwie rzeczy (pogrubione) mogą powodować u ciebie problem, grafika dość słaba, a i Ram najlepiej mieć w Dual Chanel.

Czyli ja bym doradził Ci dokupić drugą kość Ram 8GB, to już poprawić powinno działanie gier, a potem zmiana grafiki na coś chociażby pokroju GTX 1060 3GB

Link to post
Share on other sites

Inna jeszcze mozliwosc do wyprobowania to usun sterowniki karty graficznej i zainstaluj na nowo sprzed 2 miesięcy.

U mnie na gtx 1060 najnowsze sterowniki powodowaly problem z wczytywaniem gier gdzie calosc zawieszala sie ze nawet do pulpitu nie dalo rady wyjsc, na sterownikach sprzed kilku miesiecy wszystko dziala cacy

Link to post
Share on other sites

Napisze to jeszcze raz bo widzę że nie każdy rozumie  :D , zmiana ustawień graficznych w grach nic nie daje , to nie może być powód braku vram bo na starej karcie miałem tyle samo czyli 2GB a nic się nie cięło.

 

Miałem jeszcze okazje mieć innego kompa z podobnymi podzespołami, identycznym procesorem tylko ze grafika była gtx 960 4gb a wczesniej jakies radeon 3gb i zrobił się taki sam problem czyli że wszystko było okej dopóki karty nie zmieniłem, nie mam już tego komputera, problemu nie udało mi się rozwiazać na tamtym, no i złośliwosć rzeczy martwych chciała i się zrobiło to samo na tym co opisałem go w tym temacie, był kolega przynosił 16gb ramu, nic to nie dało, podpinanie jego grafiki tez nie przynioslo rezultatu.

Chciałbym jeszcze podkreślic ze na starym kompie z tym gtx 960 posiadałem dysk ssd i grała cięła na hdd jak i ssd. Nie mam juz pomysłów.


Myślę, że niedokładnie wyczyściłeś sterowniki...

ale robiłem format :D

Link to post
Share on other sites

 synchronizacja pionowa daj na adaptacyjną

maksymalna liczba wstępnie renderowanych klatek daj na 1

wstępne renderowanie klatek wirtualnej rzeczywistości daj na pod kontrolą aplikacji

potrójne buforowanie na włączone

wygładzanie korekcji gamma na wyłączone

zamknięcie środowiska możesz spróbować dać na wydajność

 

i sprawdź czy będzie coś lepiej . Jak nie będzie to już nie wiem o co kaman ;)

Link to post
Share on other sites

 

 

Zasilacz 450w(nie pamiętam nazwy)

Jeśli to jakiś tani noname to można sprawdzić na innym czy jest tak samo. Ale bardziej wygląda to na problem z vram, ewentualnie z ramem albo sterownikami. Vram można raczej wykluczyć bo wcześniej było tyle samo, sterowniki też bo był format. Dla pewności sprawdź pamięć memtestem.

Link to post
Share on other sites

co z tego , ze wcześniej  miał tyle samo vram, jak karta to był jakiś biurowy szrot, więc nawet tego nie zauważał - teraz ma kilka razy szybszą kartę, więc vram staje sie hamulcem ręcznym, jak przesadzi z ustawieniami graficznymi i go brakuje

to samo mam u siebie na swojej 1060 3gb - jak gra korzysta z wiekszej ilości vram a nie zejdę z suwakami to tak samo tnie , zrzuca fps, że nie da się grać (Wolfenstein 2np), ale daje med/high i z 45 kl/s robi się 90-100

Edytowane przez k0chan
Link to post
Share on other sites

 

 

co z tego , ze wcześniej miał tyle samo vram, jak karta to był jakiś biurowy szrot, więc nawet tego nie zauważał

Faktycznie masz racje, nie wziąłem tego pod uwagę. Ale z drugiej strony:

 

 

zmiana ustawień graficznych w grach nic nie daje

Nie wiem jak reszta tych gier ale gta v i wiedźmin 3 na niskich-średnich na pewno nie wykorzystują pełnych 2gb vram (mowa o Full HD 1080p)

 

 

 

przy włączeniu gta 5 jest wszystko okej ale tnie mi cała mapa kiedy przesuwam myszką, pod czas rozgrywki przycięcia występują po czasie co raz częściej

Z gta v miałem tak że zajmował coraz więcej ramu wraz z upływem czasu. Możliwe że ramu brakuje i swapuje pamięć wirtualną co może powodować takie właśnie przycięcia jak opisujesz.

 

Ogólnie to sobie tak dyskutujemy i rzucamy różne propozycje a wystarczy odpalić jakiś program monitorujący w tle (polecam hwinfo, zakładka sensors) i powinno być widać jak na dłoni co powoduje spadki fps (z naciskiem na zużycie ram i vram). Dziwne jest tylko to że problem wystąpił 2 razy po wymianie karty z AMD na nvidie. Niech OP jeszcze poda rozdzielczość monitora bo ani razu nie padła w tym temacie.

Link to post
Share on other sites

 

 

Nie wiem jak reszta tych gier ale gta v i wiedźmin 3 na niskich-średnich na pewno nie wykorzystują pełnych 2gb vram (mowa o Full HD 1080p)
 

 

Wiedźmin 3 nawet na maksymalnych ustawieniach (z wyłączonym HW) w 1080p nie dobija do 2GB alokacji pamięci vram. Z tego co pamiętam to użycie jest na poziomie 1,7/1,8 GB.

 

 

 

Ogólnie to sobie tak dyskutujemy i rzucamy różne propozycje a wystarczy odpalić jakiś program monitorujący w tle (polecam hwinfo, zakładka sensors) i powinno być widać jak na dłoni co powoduje spadki fps (z naciskiem na zużycie ram i vram).

 

 

Niekoniecznie. Na samym wskaźniku użycia RAM'u nie sprawdzisz, czy problem nie występuje czasem po stronie jednokanałowej pracy pamięci.

Link to post
Share on other sites

co z tego , ze wcześniej  miał tyle samo vram, jak karta to był jakiś biurowy szrot, więc nawet tego nie zauważał - teraz ma kilka razy szybszą kartę, więc vram staje sie hamulcem ręcznym, jak przesadzi z ustawieniami graficznymi i go brakuje

to samo mam u siebie na swojej 1060 3gb - jak gra korzysta z wiekszej ilości vram a nie zejdę z suwakami to tak samo tnie , zrzuca fps, że nie da się grać (Wolfenstein 2np), ale daje med/high i z 45 kl/s robi się 90-100

 

sprawdziłem tak jak mówisz, z szedłem do poziomu ustawień gdzie vramu było tyle że nawet trochę zostało nieużytego i występują te same problemy co wcześniej

Faktycznie masz racje, nie wziąłem tego pod uwagę. Ale z drugiej strony:

 

 

Nie wiem jak reszta tych gier ale gta v i wiedźmin 3 na niskich-średnich na pewno nie wykorzystują pełnych 2gb vram (mowa o Full HD 1080p)

 

 

 

Z gta v miałem tak że zajmował coraz więcej ramu wraz z upływem czasu. Możliwe że ramu brakuje i swapuje pamięć wirtualną co może powodować takie właśnie przycięcia jak opisujesz.

 

Ogólnie to sobie tak dyskutujemy i rzucamy różne propozycje a wystarczy odpalić jakiś program monitorujący w tle (polecam hwinfo, zakładka sensors) i powinno być widać jak na dłoni co powoduje spadki fps (z naciskiem na zużycie ram i vram). Dziwne jest tylko to że problem wystąpił 2 razy po wymianie karty z AMD na nvidie. Niech OP jeszcze poda rozdzielczość monitora bo ani razu nie padła w tym temacie.

 

 

rodzielczość monitora to 1920x1080 

Ok to zrobię te 3 rzeczy:

 

1.pobawię się ustawieniami karty graficznej

2. zrobie test memtestem tylko jak?

3. a hwinfo jak sprawdzic ? po jakims czasie czy niebieżąco?

 

 

Wiedźmin 3 nawet na maksymalnych ustawieniach (z wyłączonym HW) w 1080p nie dobija do 2GB alokacji pamięci vram. Z tego co pamiętam to użycie jest na poziomie 1,7/1,8 GB.

 

 

 

 

 

Niekoniecznie. Na samym wskaźniku użycia RAM'u nie sprawdzisz, czy problem nie występuje czasem po stronie jednokanałowej pracy pamięci.

 

 

 

dokładnie , wiedzminie nie dobija do 2gb vramu a i tak problem występuje

Po za tym napisałem że miałem podobnym problem na konfiguracji i5 4460 8gb dual chanel i gtx 960 4gb a wczesniej jakis radeon 3gb

i wlasnie problem wystąpił po zmianie karty więc krotko mowiąc na tamtym komputerze nie powinine wystąpic zaden problem a jednak wiec przyczyna musi byc gdzies indziej

Link to post
Share on other sites

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Odpowiedz w tym wątku...

×   Wklejono zawartość z formatowaniem.   Usuń formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

Ładowanie
  • Ostatnie aktualizacje statusu

    • WojTECH

      Pracujemy nad przywróceniem działania Tapatalk. Zostanie też uruchomiony kanał RSS. Reszta zgłoszonych problemów w działaniu forum jest już niezależnie rozwiązywana. 
      · 3 odpowiedzi
    • VindoV

      Wczoraj o 12 zamówione cloudy II na niemieckim amazonie za 50 euro, planowana dostawa pod drzwi początkowo była na piątek, wieczorem zmienili na czwartek, a przed chwilą gość mi je przyniósł, miła niespodzianka:)
      · 1 odpowiedź
    • ernorator

      Ktoś posiada jakieś miejsce gdzie można iso recovery acera dostać, model 5749z. Znalazłem tylko Siergieja, który chce 10$ na payapala.
      · 1 odpowiedź
    • Arthass

      Zweryfikuj wiek przed kliknięciem. Parental Advisory Explicit Content.
       
      · 1 odpowiedź
    • wojciechu15

      Ogarnijcie sobie sygnaturki w profilach, bo nowy layout robi odstępy między wersami jak ktoś miał enterem przerzucone wersy i większość ma te sygnaturki strasznie rozwleczone. 
      · 2 odpowiedzi
×
×
  • Dodaj nową pozycję...