Skocz do zawartości


Uwaga, ta strona używa Cookies
Stosujemy je, aby ułatwić Tobie korzystanie z naszego serwisu. Pamiętaj, że w każdej chwili możesz zmienić ustawienia dotyczące Cookies w ustawieniach swojej przeglądarki internetowej.
Dowiedz się więcej    
Akceptuję

Marcin-prv

Rejestracja: 09 lis 2008
OFFLINE Ostatnio: 29 sty 2018 15:30
*****

Moje posty

W temacie: Artykuł - uruchomienie SSD M.2 NVMe na starszych płytach głównych

28 marzec 2017 - 00:29

ok to jak już piszesz, to opisz dokłądnie po pierwsze czemu na niektórych płytach mimo PCI-e 2.0, można mieć PCI-e 3.0 ( opisz że prędkość jest ograniczana przez rozdzielacz PCI, gdy jest obecny, np w płytach posiadających 2 PCI-e x16 podpiętych bezpośrednio pod CPU, to musi być albo 2.0, albo 3.0. Lecz gdy go nie ma, to prędkość nie jest ograniczana niczym przez płytę i zależy tylko od CPU i może być 3.0. czy 2.0. Bo te punkty bez wyjaśnienia, i znajomości tematu, mogą być zbyt mylące

Ta informacja może ucieszyć wielu posiadaczy procesora z rodziny IB 

 

wyjaśnisz to v2, bo nie mogę znaleźć info na ten temat ( czym to się różni od zwykłych modułów NVMe ? ) 


Oraz napisz tam realne prędkości w tabelce prędkości PCI-e ( możesz też wyjaśnić czemu takie różnice między teoretyczną prędkością złącza, a faktyczną przy przesyłaniu danych )  

 

UEFI z NVMe jest już wgrany i komputer nadal działa, ale nie obyło się bez problemów. Okazało się, że instrukcje ASUS'a odnośnie używania funkcji Flashback są niekompletne. Udało mi się dopiero z trzecim pendrive i tak naprawdę nie jestem pewny co zrobiłem - wszystkie były sformatowane na FAT32 i zawierały jeden plik z UEFI ze zmienioną nazwą na P9X79PRO.CAP. Rozwiązaniem problemu prawdopodobnie okazała się zmiana etykiety na pendrive na bardzo prostą (użyłem nazwy 16GB).

Wracając do nazewnictwa plików CAP flashowanych w Flashback - to jakieś jedno wielkie nieporozumienie.
ASUS nie ułatwia używania tego narzędzia, gdyż jego instrukcje są nieaktualne, jedynie właściciele modeli z chipsetem X99 mają szczęście: Link. Dla starszych płyt jakimś cudem zachowała się chińska wersja: Link (trzeba pamiętać, że zamiast ROM ma być CAP).

Za chwilę przygotuję instalacyjną wersję systemu Windows 10 (1703) na pendrive pod UEFI i spróbuję go zainstalować.

A dopowiadając na Twojego posta...
Postaram się poszukać informacji o których napisałeś i je wytłumaczyć.

Odnośnie modułu NVMe v2 - to najnowsza nieskompresowana wersja pliku fft o wielkości 29KB została skompilowana przez EDK2 Team, dodatkowo utworzono skompresowaną wersję o wielkości 16KB dla osób które mają problem z niewystarczającym wolnym miejscem w UEFI. Podobno ta wersja ma bezproblemowo obsługiwać nowe M.2 NVMe takie jak Samsung SSD 960 - za chwile się o tym przekonam :)

 

Update 1...

Microsoft właśnie wypuścił Windows 10 Redstone 2 RTM aka Windows 10 Creators Update, no to teraz czeka mnie pobieranie 11GB i tworzenie nowego ISO :P

Update 2...

Narazie uruchomiłem to na systemie z Samsunga 840 Pro wszystko działa, obecnie na standardowym sterowniku NVMe od Microsofty (później zainstaluję sterownik Samsunga).

Jak widać na obrazku, Samsung SSD 960 EVO działa na magistrali PCI-E 3.0 x4.

vGgFyyo.jpg

 

Teraz poczekam aż pobierze się nowszy Windows i będę go instalował na M.2
 

Update 3 (ostatni)...

Pe07HZS.jpg

 

Krótko mówiąc, ta pamięć miażdży!!!
Na mojej płycie opartej o chipset X79 wszystko działa idealnie, łącznie z funkcją Fastboot!

Samusung 960-tka jest widoczna w UEFI (ale dopiero po zainstalowaniu na niej systemu Windows 10).
Jak już jestem przy Windows 10, to teraz bootuje w około 4 sekundy! icon_biggrin3.gif

Jeżeli interesują was wyniki testów to, wszystko pojawi się niedługo (koniec tego lub początek przyszłego tygodnia) na mojej stronie.

Pozdrawiam!

P.S.

Szczerze mówiąc, to kupowałem ten M.2 w ciemno i nie byłem przekonany, że zadziała jako systemowy... ale ryzyko się opłaciło! icon_wink2.gif


UPDATE
 
Właśnie przygotowują test w którym wezmą udział:
 
1. kilkuletni HDD Seagate 4TB
2. Samsung SSD 840 PRO 256GB (SATA AHCI)
3. Samsung SSD 840 PRO 256GB RAPID Mode (cache z RAMu) (SATA AHCI)
4. Samsung SSD 960 EVO 500GB (PCI-E 3.0 x4 -> M.2 NVMe 1.2)
 
Wszystkie powyższe zostaną przetestowane w:
 
1. Kopiowanie (RAM ->Testowy) 1 plik 3.38GB
2. Kopiowanie (Testowy ->Testowy) 1 plik 3.38GB
3. Kopiowanie (RAM ->Testowy) 5533 plików 1.72GB
4. Kopiowanie (Testowy ->Testowy) 5533 plików 1.72GB
5. Czas kompresji 5533 plików 1.72GB w WinRAR
6. Czas instalacji (RAM -> Testowy) Fallout 4
7. Czas skanowania 5533 plików 1.72GB w Windows Defender
8. Czas konwersji pliku MP4 w Premiere Pro
9. Test w Anvil's Storage Utilities 1.1.0
10. Test w AS SSD Benchmark 1.9
11. Test w ATTO Disk Benchmark 3.05
12. Test w CrystalDiskMark 5.2.1
13. Test PCMark 8 v2.7.613 Storage
14. Porównanie temperatur i zużycia prądu
 
Artykuł pojawi się w przyszłym tygodniu na mojej stronie: http://www.firstever.eu

W temacie: Artykuł - uruchomienie SSD M.2 NVMe na starszych płytach głównych

22 marzec 2017 - 12:49

Ja mam Samsunga 950 Pro na Z68, jak byś potrzebował jakieś testy z tym chipsetem.

Super, na końcu artykułu mogę zamieścić listę z zestawieniem różnych konfiguracji sprzętowych i wyników.

 

Update: Sprzęty dotarł, czas zabrać się za modowanie UEFI...

 

BNbFuIL.jpg


W temacie: Artykuł - uruchomienie SSD M.2 NVMe na starszych płytach głównych

21 marzec 2017 - 20:20

jest od groma takich artykułów, tylko po angielsku, bierzesz moduły od nvme z UEFI  wyższych chipsetów i dodajesz do swojego ( później modlisz się że starczy pamięci i nie wywali jakichś błędów/niezgodności parametrów i na końcu flash zmodyfikowanego bios-u ), gdyby mi CPU obsługiwało PCI-e 3.0 to też bym pewnie miał dysk NVMe u siebie, niestety mam SB, więc max co osiągnę to 1600Mb/s :(, więc mało się opłaca  )  


Tutaj jeszcze można powiedzieć ciekawostkę, płyty tylko z jednym portem PCI-e wspierają 3.0 ( bo nie mają "PCI Express switch" ) nawet na chipsetach P67 i H67, tylko że co mi po tym, że stara płyta wspiera PCI-e 3.0, jak nie mam drugiego PCI-e żeby włożyć adapter PCI-e x4 -> M.2 i podpiąć dysk NVMe pod kartą graficzną, no chyba że ktoś na integrze jedzie ( oczywiście potrzeba CPU wspierającego PCI-e 3.0 i uefi na płycie wspierającego ten CPU )  

 

Wyciąganie modułów NVMe z UEFI od innych modeli płyt nie jest już konieczne, gdyż został opracowany nowy moduł w wersji 2 (stworzony przez EDK2 Team) - również dla najnowszych i najwydajniejszych pamięci M.2 (Samsung SSD 960). Z tym modleniem to też nie tak, po prostu jak moduł NVMe nie zmieści się w wolne miejsce UEFI to edytor wywali błąd i chyba nikt normalny już nie będzie flashował takiego UEFI. Rozwiązanie jest proste - można usunąć wszystkie sterowniki od DpcDxe do Udp6Dxe, jeżeli nie korzystasz z opcji UEFI network boot i tym samym zwiększyć wolne miejsce dla modułu NVMe.

 

W moim artykule napisałem o tych wszystkich Z68, P67, H67 i H61 i zależnościach względem używanego procesora. Prawdopodobnie jutro dodam instrukcję jak flashować i wyniki testów.