Skocz do zawartości


Uwaga, ta strona używa Cookies
Stosujemy je, aby ułatwić Tobie korzystanie z naszego serwisu. Pamiętaj, że w każdej chwili możesz zmienić ustawienia dotyczące Cookies w ustawieniach swojej przeglądarki internetowej.
Dowiedz się więcej    
Akceptuję
Zdjęcie

Problem z dyskiem SSD NVME


  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 someone1989

someone1989
  • Nowicjusz

  • 23 postów

Napisano 17 wrzesień 2020 - 11:20

Witam.

 

Posiadam dysk ADATA SX8200 Pro.

 

Według danych posiada on zapis na poziomie 2300 a odczyt 3500. Oczywiście są to wartości max.

 

Płyta główna posiada radiator na dysk NVME stąd podczas testów AS SSD Benchmark 10GB dysk osiągał maksymalnie 49 stopni ( w spoczynku ma stałe 40-41 ) także raczej od przegrzewaniu nie ma tutaj mowy.

 

Wynik w AS SSD to odpowiednio 2790 mb/s i 916 mb/s.

 

Rozumiem przez to, że podczas kopiowania jakiegoś pliku (akurat 1 plik 7GB) z jednej partycji SSD na drugą SSD będzie się kopiował z prędkością ok 900mb/s (do 2300 daleko...).

 

Niestety u mnie kopiowanie odbywa się z prędkością na starcie ok 500mb/s i od razu spada do ok 200-300mb/s.

 

Czy to jest normalne działanie dysku? Skoro producent podaje up 2300, testy wyciskają w granicach 900mb/s to chyba kopiowanie powinno odbywać się z większą predkością niż 200mb/s ...

 

Jak kopiuje na hdd jest ok 90 mb/s ale to wynika akurat z ograniczeń HDD. Martwi mnie tak niskie wartości przy kopiowaniu z SSD na SSD i nie wiem czy to normalne czy jest coś nie tak z tym dyskiem.


  • 0

#2 kokosnh

kokosnh
  • Maniak

  • 12211 postów
  • 3DMark 06:24404

Napisano 17 wrzesień 2020 - 12:08

puść atto na domyślnych, możesz zmienić I/O Size początkowe na 32MB.

 

Pamiętaj też że zapis 2300MB/s to tylko w obrębie bufora pseudoSLC 

 

po prędkości, stawiam że masz wersję 512GB. 

 

pytanie po prostu, czy nie kończy ci się bufor... jak dla mniejszych próbek 1GB ? 

 

8861_005_adata-sx8200-pro-512gb-nvme-ssd


  • 0

Spoiler
 

#3 someone1989

someone1989
  • Autor tematu
  • Nowicjusz

  • 23 postów

Napisano 17 wrzesień 2020 - 12:46

Mój błąd nie podałem info tak jest to 512GB mam 2 partycje. C to wolne 61gb z 183gb a E to 24GB z 292GB.

 

Często jest też taki dziwny objaw przy oglądaniu zdjęć. Klikam sobie ileś tam zdjęć i za każdym razem otwiera się błyskawicznie, ale przy którymś tam z rzędu nagle otwiera się podgląd na biało bez zdjęcia. Jak zamknę i kliknę jeszcze raz to myśli z dobre kilkadziesiąt sekund i dopiero otwiera podgląd z zdjęciem.

 

Czasami mam też tak, że otwierając przeglądarkę (kilkadziesiąt zakładek) zaczyna troszkę jakby mulić słychać w tle jakby coś odczytywał z dysku HDD a przecież system i przeglądarka stoją na SSD. System również nie był przenoszony z HDD na SSD tylko na nowo stawiany a dysk HDD na którym był system został sformatowany.

 

Wszystko działało ok te kilka miesięcy i dopiero teraz takie coś się dzieje.

 

screeny atto dla partycji c i e

 

atto-c.jpg

 

atto-e.jpg


Użytkownik someone1989 edytował ten post 17 wrzesień 2020 - 12:47

  • 0

#4 Didox

Didox
  • Entuzjasta

  • 682 postów
  • Miejscowość:Katowice

Napisano 17 wrzesień 2020 - 18:03

Niepartycjonuje się dysków SSD. Dyski te "lubią" jak nie są zapełnione pod korek. W dużym uproszczeniu stąd też różne wyniki na różnych partycjach mimo że dysk ten sam, wydajność będzie tym mniejsza jak ilość pozostałego miejsca. 

 

Co do tego że coś tam się dzieje na hdd w tle, zależy co masz zainstalowane, może jakiś inny program który chodzi w tle, się aktualizuje, może w tle włączył się skaner antywirusowy i "idzie" przez pliki. 


Użytkownik Didox edytował ten post 17 wrzesień 2020 - 22:49

  • 0

"To boldly go where no one has gone before"


#5 wodego

wodego
  • Nałogowiec

  • 1548 postów

Napisano 17 wrzesień 2020 - 19:37

Niepartycjonuje się dysków

Uzasadnij jakiego odkrycia dokonałeś.

 

Dodaj jeszcze, że jest zakaz instalowania linuksa na SSD, bo linuks domyślnie tworzy partycje. A jak jeszcze ktoś postawi linuksa obok windowsa, to będzie płacił karę.


  • 2

#6 Didox

Didox
  • Entuzjasta

  • 682 postów
  • Miejscowość:Katowice

Napisano 17 wrzesień 2020 - 22:47

@wodego dzięki, z tym partycjonowaniem dysków SSD to tutaj bije się w pierś. Przeprowadziłem autodiagnostyke, i wydaje się że te wpisy do pamięci miały miejsce w okolicach 2013, pewnie jakieś pierwsze forumowe urban-legends z dyskami SSD. Nie znalazłem informacji na poparcie tej tezy. Dane zostały skorygowane  ^^


  • 0

"To boldly go where no one has gone before"


#7 wodego

wodego
  • Nałogowiec

  • 1548 postów

Napisano 18 wrzesień 2020 - 06:35

@Didox, brawo za zgłębienie tematu. Dużo osób nie lubi przyznawać się do pomyłek.

 

Partycjonowanie dysków jest tylko dla użytkownika. Dla kontrolera nie ma znaczenia gdzie leżą dane. Kontroler nie wyodrębnia fizycznie jakiegoś obszaru pamięci nand na partycje i tam zapisuje dane, tylko dane są porozrzucane w zależności od algorytmu. Tak więc nie ma sytuacji, że dany obszar pamięci jest dużo częściej zapisywany, bo przecież użytkownik zrobił partycję. Jest inaczej niż w HDD, bo tam rzeczywiście fizycznie był obszar z daną partycją.


  • 1

#8 someone1989

someone1989
  • Autor tematu
  • Nowicjusz

  • 23 postów

Napisano 18 wrzesień 2020 - 07:00

Co do tego że coś tam się dzieje na hdd w tle, zależy co masz zainstalowane, może jakiś inny program który chodzi w tle, się aktualizuje, może w tle włączył się skaner antywirusowy i "idzie" przez pliki. 

Tylko to się dzieje akurat zazwyczaj kiedy otwieram przęglądarkę internetową albo przeglądam zdjęcia. Obydwie aplikacje są na SSD bo to systemowe aplikacje. Antywirusa mam ustawionego na ręczne skanowanie. Programów w tle staram się nie mieć automatycznie jak jakiś program przy instalacji ustawia sobie autostart z systemem to też to zmieniam.

 

Na HDD tak na dobrą sprawę mam tylko kopie plików oraz gry, które nie muszę trzymać na SSD jakieś stare tytułu, proste gry a nie rozbudowane nowe produkcje AAA, więc nie muszą być na SSD. 

 

Dlatego to mnie dziwi. Zachowuje się to tak jakby przeglądarka zdjęć czy internetu była zainstalowana na HDD a nie SDD, albo jak zdjęcia byłyby na HDD a tak nie jest. Ba nawet kiedyś jak miałem tylko HDD to nie przypominam sobie sytuacji by nie załadował mi się w programie podgląd zdjęcia... może trwało otwieranie dłużej, ale zdjęcie się otwierało.

 

Wygląda to tak jakby system raz na x razy nie potrafił znaleźć katalogu od skrótu na SSD i szukał go na HDD chociaż to idiotyzm tak to wygląda.

 

Chyba znajdę chwilę czasu i rozbebesze go by dokopać się do dysków HDD i je wyciągne i zobacze przez kilka dni co się będzie działo bo już głupieje przez to.

 

 

PS. Ma ktoś info gdzie można kupić ten dysk BPX Pro? Co to w ogóle za twór? Znalazłem tylko wersje 1TB i 2TB na amazonie.

 

Druga kwestia jak się ma Patriot VPN100 256 / 512 do tej ADATY? też po około 20% tak spada transfer? To jest dziadostwo by po 20% już spadała tak drastycznie prędkość oznaczało by to, że na 512gb dysku można trzymać 100GB by nie tracić prędkości jak dobrze rozumuje ten wykres


Użytkownik someone1989 edytował ten post 18 wrzesień 2020 - 07:07

  • 0

#9 kokosnh

kokosnh
  • Maniak

  • 12211 postów
  • 3DMark 06:24404

Napisano 24 wrzesień 2020 - 22:07

te wykresy przedstawiają jak zachowują się bufory pseudoSLC na pustym SSD. Zazwyczaj są to dynamiczne bufory pseudoSLC i zmniejszają swój rozmiar wprost proporcjonalnie do zapełniania SSD, ale zazwyczaj zostaje tam kilka do kilkunastu GB, nawet jak jest dość wypełniony. 

 

Takie bufory, maja za zadanie ukryć gorszą wydajność kostek TLC. 99% użytkowników nie zapisuje więcej niż kilka GB na raz, więc póki nie wypełnią SSD pod korek, to nie odczują prawdziwej prędkości SSD, przy zapisie bezpośrednio do TLC. 

 

No i fajnie na benchmarkach i testach wypadają  :rotfl:

 

Ps. Nie szukaj SSD do kupienia (BPX Pro) na podstawie jednego wykresu... 

 

​Pamiętaj też, że im większy SSD, tym szybciej może zapisywać (bo zapis może się odbywać równolegle do większej ilości kostek NAND) więc twój model, tylko 1TB, by spadał do około 1000MB/s zamiast 500MB/s. 

Dlatego tez się mówi, że zawsze lepiej jeden większy SSD, niż kilka małych... 

 

Co do twoich problemów, to może być to masa rzeczy, na serio... 

 

​Jak będę mieć chwilę, to przejrzę i spróbuję coś napisać sensownego. 

 

Co do partycji na jednym SSD, to nie mają one związku na prędkość, bufor pseudoSLC, TRIM, czy Wear Leveling. 


  • 0

Spoiler
 

#10 someone1989

someone1989
  • Autor tematu
  • Nowicjusz

  • 23 postów

Napisano 02 październik 2020 - 17:59

Ok będę wdzięczny za info co z tym zrobić. Może jakaś optymalizacja czy coś... Ja się na ssd praktycznie nie znam. Mam slot x4, dysk up to 2300 zapis a nagle widzę 500 i spada w dół to jest dla mnie coś nie tak stąd mój post by się dowiedzieć więcej co i jak i zrozumieć działanie SSD.

 

Może i racja by po 1 wykresie nie kupować, ale potrzebuje 2 dysk myśle 256 będzie optymalny tylko i wyłącznie by za pomocą rozwiazania amd (mam płytę b450) połączyć go z HDD 2 TB. Ogólnie drugi port na płycie jest już x2 czyli tam mniejsze transfery będą, ale i tak powinno to przyspieszyć HDD


  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych