Skocz do zawartości


Uwaga, ta strona używa Cookies
Stosujemy je, aby ułatwić Tobie korzystanie z naszego serwisu. Pamiętaj, że w każdej chwili możesz zmienić ustawienia dotyczące Cookies w ustawieniach swojej przeglądarki internetowej.
Dowiedz się więcej    
Akceptuję
Zdjęcie

OBS stream czarny ekran


  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 Sharimsejn

Sharimsejn
  • Dyskutant

  • 191 postów

Napisano 05 listopad 2017 - 19:23

Hej. Na wstępie napiszę, że chyba wypróbowałem większość rozwiązań i dalej nic. Mianowicie zainstalowałem OBS i użyłem tej wersji beta by samo dostosowało ustawienia do mojego sprzętu i połączenia. 

Gdy odpalę grę w trybie pełnoekranowym (Wolfenstein nowy) to uruchamiam OBS i wchodzę w dodanie sceny>przechwytywanie gry>przechwytywanie aplikacji ekranowej to mam czarny ekran ale dźwięk normalnie odtwarza.

 

Zmieniam więc strategię i jeszcze raz w przechwytywaniu gry zmieniam na "przechwytuj konkretne okno"> z listy wybieram grę. Dodam, że przed zmianą trybów z pełnego okna na okno restartowałem grę i OBS i efekt zawsze ten sam, dźwięk jest, a obrazu nie ma.

Dodatkowo gra jak i OBS jest uruchamiany jako administrator, a OBS nawet próbowałem za radą ustawić w trybie zgoności z windows 7 mimo, że posiadam Windows 7 SP1. Odnośnie systemu to taka mała dygresja, że uruchomiłem ostatnio test VR ze Steam i po zakończeniu testu pokazało mi, że nie mam SP1 chociaż wiem, że mam bo kiedyś gry nie mogłem bez tego uruchomić i po instalacji SP1 już grałem normalnie.

 

Jakieś porady?

 

Mój sprzęt:

i5-3570k

MSI RX480 8GB
16GB ram
SSD 256GB


Użytkownik Sharimsejn edytował ten post 05 listopad 2017 - 19:24

  • 0

#2 supervisor

supervisor
  • Bywalec

  • 135 postów

Napisano 05 listopad 2017 - 20:02

Spróboj przez przechwytywanie ekranu. Wolfenstein używa opengl i vulkana, więc jest trochę niestandardowy.


Użytkownik supervisor edytował ten post 05 listopad 2017 - 20:03

  • 0

Platforma robocza: Ryzen 1700x, RX 480 (8GB), X370 Prime Pro, 32GB Ram (3000MHz), 7TB (3x HDD) +240GB (NVMe SSD) + 512GB (SATA SSD), Xonar DX, Iiyama XUB3490WQSU-B1 34" (3440x1440). Wacom Intuos 5 Touch XL.

 

 


#3 Sharimsejn

Sharimsejn
  • Autor tematu
  • Dyskutant

  • 191 postów

Napisano 05 listopad 2017 - 20:19

Niestety to samo. Dźwięk jest ale bez obrazu :/

 

EDIT. Dodam, że w którymś trybie miałem tak, że jak wychodziłem do menu gry to mi je pokazywało na streamie, a po powrocie do rozgrywki pojawiał się czarny ekran. 


Użytkownik Sharimsejn edytował ten post 05 listopad 2017 - 21:24

  • 0

#4 supervisor

supervisor
  • Bywalec

  • 135 postów

Napisano 06 listopad 2017 - 00:15

Niestety to samo. Dźwięk jest ale bez obrazu :/

 

EDIT. Dodam, że w którymś trybie miałem tak, że jak wychodziłem do menu gry to mi je pokazywało na streamie, a po powrocie do rozgrywki pojawiał się czarny ekran. 

Szybka lektura po angielsku każe mi twierdzić że OBS nie da rady. Spróbuj narzędziami nvidii lub amd.


Użytkownik supervisor edytował ten post 06 listopad 2017 - 03:16

  • 0

Platforma robocza: Ryzen 1700x, RX 480 (8GB), X370 Prime Pro, 32GB Ram (3000MHz), 7TB (3x HDD) +240GB (NVMe SSD) + 512GB (SATA SSD), Xonar DX, Iiyama XUB3490WQSU-B1 34" (3440x1440). Wacom Intuos 5 Touch XL.

 

 


#5 Sharimsejn

Sharimsejn
  • Autor tematu
  • Dyskutant

  • 191 postów

Napisano 06 listopad 2017 - 01:59

Tzn. jaka lektura? No i musi być jakieś rozwiązanie bo nie chce mi się wierzyć, że tylko u mnie i może kogoś jeszcze trzeba pozbyć się OBS. Dodam na marginesie, że kompletnie nie wiem jak się obchodzić z ReLive od AMD mimo, że ma pięć funkcji na krzyż. Zalogowałem się w twitch poprzez ReLive i jak wciskam skrót klawiszowy wy wybrać stream z listy albo używam skrótu bezpośrednio do stream do nie działa. Nic się nie dzieje i wolałbym jednak wrócić do tematu OBS :)


  • 0

#6 supervisor

supervisor
  • Bywalec

  • 135 postów

Napisano 06 listopad 2017 - 03:16

Przede wszystkim przełącz na OpenGL i w tym trybie próbuj.


  • 0

Platforma robocza: Ryzen 1700x, RX 480 (8GB), X370 Prime Pro, 32GB Ram (3000MHz), 7TB (3x HDD) +240GB (NVMe SSD) + 512GB (SATA SSD), Xonar DX, Iiyama XUB3490WQSU-B1 34" (3440x1440). Wacom Intuos 5 Touch XL.

 

 


#7 Sharimsejn

Sharimsejn
  • Autor tematu
  • Dyskutant

  • 191 postów

Napisano 06 listopad 2017 - 14:10

Tzn. gdzie mam to zmienić? Chyba nie ogarnąłem.


  • 0

#8 supervisor

supervisor
  • Bywalec

  • 135 postów

Napisano 06 listopad 2017 - 15:30

Tzn. gdzie mam to zmienić? Chyba nie ogarnąłem.

W opcjach w grze.


  • 0

Platforma robocza: Ryzen 1700x, RX 480 (8GB), X370 Prime Pro, 32GB Ram (3000MHz), 7TB (3x HDD) +240GB (NVMe SSD) + 512GB (SATA SSD), Xonar DX, Iiyama XUB3490WQSU-B1 34" (3440x1440). Wacom Intuos 5 Touch XL.

 

 


#9 Sharimsejn

Sharimsejn
  • Autor tematu
  • Dyskutant

  • 191 postów

Napisano 06 listopad 2017 - 23:35

W nowym Wolfensteinie nie ma czegoś takiego żeby zmienić takie opcje. W ogóle dodam, że w mało której grze idzie coś takiego zmienić. 


  • 0

#10 xGatki

xGatki
  • Bywalec

  • 149 postów

Napisano 07 listopad 2017 - 02:59

To przechwytuj ekran i po problemie. :D


  • 0

#11 Sharimsejn

Sharimsejn
  • Autor tematu
  • Dyskutant

  • 191 postów

Napisano 08 listopad 2017 - 14:29

Jest dźwięk i nie ma obrazu. Nie mam już pomysłów. Pomocy :C

 

EDIT. Zaczyna mnie to trochę irytować. Kiedyś w OBS ustawiłem parę opcji pod twitcha by nie cięło, wybierałem przechwytywanie gry i wybierałem ją z listy, a teraz takie cyrki.


up?


Użytkownik Sharimsejn edytował ten post 07 listopad 2017 - 15:54

  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych