Skocz do zawartości


Uwaga, ta strona używa Cookies
Stosujemy je, aby ułatwić Tobie korzystanie z naszego serwisu. Pamiętaj, że w każdej chwili możesz zmienić ustawienia dotyczące Cookies w ustawieniach swojej przeglądarki internetowej.
Dowiedz się więcej    
Akceptuję
Zdjęcie

Problem z dyskiem M.2 - błąd kontrolera

dysk kontroler błąd NVMe

Najlepsza odpowiedź Marqvs, 26 maj 2017 - 19:26

Problem został rozwiązany. Okazuje się, że Phison - producent kontrolera nie poszedł w ślady Samsunga i Toshiby i nie wydał oficjalnego sterownika do dysku M.2. Dziwne jest to, że support Patriota, z którym jestem w kontakcie ani słowem nie wspomniał, że istnieje nieoficjalny sterownik NVMe, który powoduje, że tytułowy błąd przestaje występować.

Rozwiązanie i link do sterownika znalazłem tu: http://forum.benchma...cie-nie-działa/

Przejdź do postu


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 Marqvs

Marqvs
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 02 kwiecień 2017 - 16:58

Witam,

Zamontowałem nowy dysk Corsair MP500 120GB M.2 NVMe, postawiłem na nim Win 10. Wszystko śmiga ale w Dzienniku zdarzeń Windows jest błąd krytyczny o treści:"Sterownik wykrył błąd kontrolera na \Device\RaidPort0."

Zwykle takie błędy dla HDD świadczyły o uszkodzeniu dysku ale nie wiem jak to jest z SSD?

Innych dysków fizycznych w komputerze nie ma. Nie mam sposobu jak spowodować aby błąd się nie pojawiał. Czy są jakieś wiarygodne programy do testowania tego typu dysków? BIOS i stery do mobo najnowsze.
96956d5ce60a.jpg


Użytkownik Marqvs edytował ten post 02 kwiecień 2017 - 17:23

  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#2 lonialomax

lonialomax
  • Maniak

  • 4040 postów

Napisano 02 kwiecień 2017 - 17:30

Konfigurowałeś w biosie dyski w system Raid? Sprawdź w biosie konfigurację kontrolera portów Sata. Powinno być AHCI.


  • 0

Mobo:  Z370 Aorus Gaming 7 - CPU: i5 9600k@4.8GHz - RAM:16GB  G Skill SniperX F4-3600 C19-8GSXKB - Grafika: GTX 1070 Extreme - Zasilacz: Corsair RM550x - Obudowa Zalman Z3 Plus


#3 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 02 kwiecień 2017 - 17:45



Konfigurowałeś w biosie dyski w system Raid? Sprawdź w biosie konfigurację kontrolera portów Sata. Powinno być AHCI.

 

Nie, RAID-a nie dotykałem. Do tego dysku oddzielnych sterowników pod Win 10 nie ma, gdyż prawdop. nie są konieczne.

14728932b502.jpg

41ff75669c90.jpg


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#4 lonialomax

lonialomax
  • Maniak

  • 4040 postów

Napisano 02 kwiecień 2017 - 18:30

Na stronie ASRock nie ma tego dysku wśród wspieranych może z stąd jakieś animozje. Sprawdź czy masz możliwość wyłączenia w biosie portów Sata 0 i Sata 1- przełącznik na disabled.


  • 0

Mobo:  Z370 Aorus Gaming 7 - CPU: i5 9600k@4.8GHz - RAM:16GB  G Skill SniperX F4-3600 C19-8GSXKB - Grafika: GTX 1070 Extreme - Zasilacz: Corsair RM550x - Obudowa Zalman Z3 Plus


#5 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 02 kwiecień 2017 - 18:53

Na stronie ASRock nie ma tego dysku wśród wspieranych może z stąd jakieś animozje. Sprawdź czy masz możliwość wyłączenia w biosie portów Sata 0 i Sata 1- przełącznik na disabled.

Dysk wyszedł na jesieni 2016 a płyta jest rok starsza, natomiast listy urządzeń ASRock chyba nie aktualizuje na bieżąco. Wyłączyć w BIOS-ie portów Sata0, Sata1 nie da się. Brak opcji "Disabled". One i tak są automatycznie wyłączone jeśli zajęty jest slot Ultra M.2

Dysk + system działa bez zarzutów. Może ten błąd to fałszywy alarm?;)


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#6 lonialomax

lonialomax
  • Maniak

  • 4040 postów

Napisano 02 kwiecień 2017 - 19:17

Nie jest to błąd krytyczny jak napisałeś więc można to ignorować tym bardziej, że nie masz konfiguracji w Raid. Zobacz jeszcze co zaproponuje narzędzie Corsair SSD Toolbox v1.2.5.5.


  • 0

Mobo:  Z370 Aorus Gaming 7 - CPU: i5 9600k@4.8GHz - RAM:16GB  G Skill SniperX F4-3600 C19-8GSXKB - Grafika: GTX 1070 Extreme - Zasilacz: Corsair RM550x - Obudowa Zalman Z3 Plus


#7 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 03 kwiecień 2017 - 18:15

Sprawdziłem, wrzucam wyniki. Nie umiem ich jednak interpretować. Intuicyjnie chyba nie mam podstaw do obaw:)?

 

222a3e4d2d2b.jpg


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#8 lonialomax

lonialomax
  • Maniak

  • 4040 postów

Napisano 03 kwiecień 2017 - 19:54

Tak jak w nagłówku SMART Status: OK więc pod tym względem można spać spokojnie. Uruchom jeszcze Zarządzanie Dyskami i zobacz jak dyski widzi Windows 10 i który dysk jest dyskiem 0.


  • 0

Mobo:  Z370 Aorus Gaming 7 - CPU: i5 9600k@4.8GHz - RAM:16GB  G Skill SniperX F4-3600 C19-8GSXKB - Grafika: GTX 1070 Extreme - Zasilacz: Corsair RM550x - Obudowa Zalman Z3 Plus


#9 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 03 kwiecień 2017 - 20:55

Tak jak w nagłówku SMART Status: OK więc pod tym względem można spać spokojnie. Uruchom jeszcze Zarządzanie Dyskami i zobacz jak dyski widzi Windows 10 i który dysk jest dyskiem 0.

 

Dysk 0 to właśnie ten Corsair. Ok, czyli zawieszam analizę błędu. Może nic złego się nie wydarzy:)


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#10 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 17 maj 2017 - 19:10

Nowe wieści o problemie. Ten sam błąd mam na Patriot Hellfire M.2 NVMe.

I co ciekawe: błąd występuje tylko na Windows 10 (każda wersja i kompilacja), natomiast na Win 8.1 nie występuje, nawet jeśli po jego instalacji komp. pracuje na domyślnych windowsowskich sterach do sprzętu.

Napisałem do Microsoftu - odesłali do producenta sprzętu. Na początek napisałem do prod. płyty głównej ASRocka. Zalecili reinstalację sterowników - nie pomogło. Poinformowali przy tym,że nie każdy dysk M.2 współpracuje z RAID.  Np. OCZ nie ale Samsung Evo - tak! Być może moje testowane dyski nie współpracują z RAID a Windows zgłasza to w postaci błędu ID 11. Poszło zapytanie do Patriota...

 

Problem z tym błędem mają też inni ludzie na innym niż mój sprzęcie: https://communities....m/thread/112870

 

Przychylam się do przypuszczeń supportu ASRocka, że to błąd Windows 10. Warto nadmienić, że Win 10 nie sygnalizuje tego jako błąd krytyczny a jako błąd ogólny.


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 


#11 Marqvs

Marqvs
  • Autor tematu
  • 0x74 = 0

  • 445 postów
  • Miejscowość:PL

Napisano 26 maj 2017 - 19:26   Najlepsza odpowiedź

Problem został rozwiązany. Okazuje się, że Phison - producent kontrolera nie poszedł w ślady Samsunga i Toshiby i nie wydał oficjalnego sterownika do dysku M.2. Dziwne jest to, że support Patriota, z którym jestem w kontakcie ani słowem nie wspomniał, że istnieje nieoficjalny sterownik NVMe, który powoduje, że tytułowy błąd przestaje występować.

Rozwiązanie i link do sterownika znalazłem tu: http://forum.benchma...cie-nie-działa/


  • 0

MS Windows 10 Home x64 | Fractal Design R5 Blackout | MSI Z270 Gaming M3 | Intel i3-6100 3,7 GHz  + SilentiumPC Fera 2 HE1224 | 2x4GB G.Skill Ripjaws 4 3200 MHz DDR4 CL16 | Intel Graphics HD 530 | SSD Patriot Hellfire M.2 NVMe 240 GB | DVD/RW Asus DRW-24D5MT | DVB-T: AverTV Volar HD 2 | BeQuiet Pure Power L8 500W | Be Quiet! Silent Wings 2  140mm | Iiyama ProLite XU2290HS 21,5'' | Motorola Moto G LTE.

 






Również z jednym lub większą ilością słów kluczowych: dysk, kontroler, błąd, NVMe

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych